Posts Tagged ‘lun’

Po instalacji w sieci SAN vMware ESXi >4.0 pojawia Ci się komunikat, że jedyna karta sieciowa jaka jest zainstalowana to vusb0?

Prawdopodobnie Twoja rama serwera nie obsługuje połączeń generacji trzeciej.

  1. Włącz Local Technical Support logując się do konsoli eSXi (F2 > login > Technical Support > Enable Local Technical Support)
  2. Wciśnij ALT+F1 i zaloguj się jako r00t z ustalonym podczas instalacji hasłem
  3. Sprawdź karty sieciowe poleceniem: #esxcfg-nics -l

Jeżeli widzisz tylko vusb0, a jesteś pewien, że posiadasz hiper wypasioną redundantną kartę z czterema portami i w tym jeszcze czterema wirtualnymi to wiedz, że coś się dzieje!

Krok #1

Należy zmienić tryb tranmisji karty sieciowej na generację pierwszą.

UEFI -> System Settings -> Device and I/O ports -> PCIe Gen1/Gen2/Gen3 Speed Selection -> CIOv I/O exp. connector oraz BladeExpander connector na Gen1.

Krok #2

Należy zaktualizować BIOS UEFI do wersji co najmniej 1.03 w sposób następujący:

  1. Włącz host w trybie maintenance (ALT+F1)
  2. Umieść nowy UEFI BIOS gdzieś w systemie
  3. Odpal # ./ibm_fw_uefi_d6e128a_linux_32-64.bin -u
  4. Pojawi się komunikat “Error flasing firmware: 3”
  5. Odpal ponownie powyższą komendę
  6. Instalacja stworzy nowy przełącznik wirtualny nazwany IBM_CDC_vSwitch0
  7. Restarcik

Krok #3

Ściągnięcie i instalacja najnowszego sterownika Emulex wspierającego rozwiązanie eSXi, najlepiej z tej strony.

Krok #4

Pobranie i instalacja vmWare eSXi 4.1 Update 3 z tej strony.

Krok #5

Po instalacji należy ustawić adres IP dla hypervisora i zrestartować moduł sieciowy. W przypadku opcji nieHA należy zaznaczyć tylko jedną kartę sieciową w trybie Connected.